Версия для печати темы

Нажмите сюда для просмотра этой темы в обычном формате

Форум «Всё о Паскале» _ Книга жалоб и предложений _ Не работают кнопки

Автор: Вячеслав Людской 12.09.2010 21:52

Здравствуйте.

Такая проблема: после переустановки браузера на IE 8 не вижу подсветку содержимого в тэге [code=pas][/code] (подсвечивалось зеленым, синим), перестали работать кнопки "Спойлер" и "+" "-" (в повышении репутации). Может быть какие-то еще кнопки не работают, пока не заметил. Нажимаю - ничего не происходит. С чем это может быть связано? Что изменить?

Автор: volvo 12.09.2010 23:06

Хм. Очень странно. Зашел только что через IE8, вот чего увидел:
Прикрепленное изображение

Репутацию не проверял, там она мне недоступна, поскольку заходил из-под гостя. На всякий случай: я через IE8 зашел в третий (если не ошибаюсь) раз, вообще я использую другой браузер, так что никаких специальных настроек не делал. Как установился - так и есть.

А ты его обновлял на какой ОСи? Обновление успешно прошло? Что с остальными сайтами, все работает, или тоже где-то да, а где-то нет?

Автор: Вячеслав Людской 14.09.2010 19:16

Нда. Не работают смайлики, не могу вставить картинку (она загружается, но непосредственно в сообщение не вставяляется). Нету подсветки, не работают кнопки. Не открывается вложенное в письма почтового ящика (mail.ru). Никаких настроек не менял. У меня Windows Xp Sp3. Все установилось хорошо, никаких ошибок не было. Сейчас попробую переустановить браузер.

Единственное - устанавливал IE8 "поверх" старого IE6. Т. е. в ту же папку. IE 6 перед этим не удалил. Могло из-за этого такое случится?

PS Картинка все-таки вставилась.


Эскизы прикрепленных изображений
Прикрепленное изображение

Автор: volvo 14.09.2010 19:43

Не знаю, как с IE6, но вот только что обновил на своем стареньком компьютере IE7 на восьмой (WinXP SP2) - полет нормальный (сразу после установки - вообще первая загрузка нового браузера):
Прикрепленное изображение

(все смайлики и кнопки работают). Кстати, Установщик IE8 сам должен удалять предыдущую версию IE. По крайней мере у меня только что было 2 перезагрузки: первая - после удаления IE7, вторая - после установки IE8. Что-то у тебя скорее всего не так поставилось. yes2.gif

Автор: Вячеслав Людской 15.09.2010 9:50

Установил Opera. Доволен. Все работает как надо. IE больше не хочу no1.gif . volvo, спасибо за участие.

Автор: Archon 25.10.2010 17:09

Вячеслав Л., у тебя был выключен JavaScript. Если включить, то и подсветка появится, и кнопки заработают.

Автор: Вячеслав Л. 25.10.2010 18:46

Не знаю.
Попытался включить: Вид - Окно языка Java. Вижу сообщение об ошибке (окно) и на экране вот это:
Прикрепленное изображение
В Сервис - Свойства обозревателя - Дополнительно (я, так, понял, там эти настройки) на пунктах "Вести журнал языка Java", "Использовать компилятор Java JIT", "Табло языка Java включено" поставил флажки.
Ничего не изменилось:
Прикрепленное изображение

Автор: Archon 25.10.2010 20:01

Нет, JavaScript и Java - это не одно и то же. На самом деле, это совершенно разные языки. Что-бы включить JavaScript в Internet Explorer зайди в Свойства обозревателя -> Безопасность -> Другой... -> Сценарии -> Активные скрипты -> Включить.
Прикрепленное изображение

Автор: Lapp 26.10.2010 7:48

[offtop]
да уж.. у меня давно уже руки чешутся посмотреть на того муд.. гм, -реца, который удумал совершенно не относящуюся к Java вещь назвать JavaScript! mega_chok.gif Интересно бы прикинуть количество всяких недоразумений из-за этого..
[/offtop]

Автор: Вячеслав Л. 26.10.2010 21:53

Ничего не изменилось. Подсветки нет, кнопки не работают. Установил флажки: "Разрешения Java - средняя безопасность", "Активные сценарии", "Выполнять сценарии приложений Java", "Разрешать сценарии". Остальное ничего не менял. Что не так?

Цитата
...руки чешутся посмотреть...
Можно записать? smile.gif

Автор: Archon 26.10.2010 21:56

Ну, попробуй поставить настройки безопасности по-умолчанию. Если не поможет, то фиг его знает =)

Автор: Вячеслав Л. 26.10.2010 22:13

Неа, не помогло. Остается только переустанавливать smile.gif

Автор: Гость 22.12.2010 0:04

У меня тоже не работают кнопки (ФФ последний версии), ява скрипт включен

Автор: volvo 22.12.2010 0:12

Цитата
У меня тоже не работают кнопки (ФФ последний версии)
И у меня ФФ последней версии, однако кнопки прекрасно работают. Что я делаю не так? (Хинт: в ФФ очень много расширений, блокирующих скрипты, хотя в общих настройках JS включен. NoScript - одно из них)